Game Control Panel Down

Incident Report for Hyper Layer

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 09:39 SAST

Investigating

Dear Customer

Please be advised that we are aware of the game control panel being offline, we are currently investigating the issue
Posted Jul 08, 2026 - 09:12 SAST
This incident affected: WEBSITES (GAME PANEL).