All rollbacks have been completed, and game servers should now be online again. If you still cannot connect please log a ticket or reply to your current open one
Posted May 04, 2026 - 18:08 SAST
Update
We have decided to rollback game servers coming back online in the next 10min
Posted May 04, 2026 - 17:43 SAST
Identified
We have ruled everything on our filter and server side. We are awaiting feedback now with the data centres as this is where we think the issue lies.
Once we get feedback and a possible fix we will update here.
Worst case senario we will rollback the changes that was made today so you can access your game servers again
Posted May 04, 2026 - 16:57 SAST
Investigating
We are aware of the connectivity issues some customers are experiencing on JHB03 following our recent maintenance window.
Our team has completed a significant infrastructure upgrade on this node and are currently working through post-deployment stabilisation. We are actively investigating the cause of the timeouts and disconnections and are working to resolve these as quickly as possible.
We apologise for the inconvenience and will provide further updates as the situation progresses.